using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"""([^""]*)"".*";
string input = @"2014-03-20 16:53:39.741 -0700 Information 638 NICOLE Client ""[WebDirect]"" opening a connection from ""24.114.54.155 (24.114.54.155)"" using ""iPad Safari 7.0 [fmwebdirect]"".
2014-03-20 16:53:39.741 -0700 Information 94 NICOLE Client ""[WebDirect] (24.114.54.155) [24.114.54.155]"" opening database ""ProShopPartner_v1"" as ""[Guest]"".
2014-03-20 16:58:45.163 -0700 Information 98 NICOLE Client ""[WebDirect] (24.114.54.155) [24.114.54.155]"" closing database ""ProShopPartner_v1"" as ""[Guest]"".
2014-03-20 16:58:45.163 -0700 Information 22 NICOLE Client ""[WebDirect] (24.114.54.155) [24.114.54.155]"" closing a connection.";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}