import re
regex = re.compile(r"\"([^\"]*)\".*")
test_str = ("2014-03-20 16:53:39.741 -0700 Information 638 NICOLE Client \"[WebDirect]\" opening a connection from \"24.114.54.155 (24.114.54.155)\" using \"iPad Safari 7.0 [fmwebdirect]\".\n"
"2014-03-20 16:53:39.741 -0700 Information 94 NICOLE Client \"[WebDirect] (24.114.54.155) [24.114.54.155]\" opening database \"ProShopPartner_v1\" as \"[Guest]\".\n"
"2014-03-20 16:58:45.163 -0700 Information 98 NICOLE Client \"[WebDirect] (24.114.54.155) [24.114.54.155]\" closing database \"ProShopPartner_v1\" as \"[Guest]\".\n"
"2014-03-20 16:58:45.163 -0700 Information 22 NICOLE Client \"[WebDirect] (24.114.54.155) [24.114.54.155]\" closing a connection.")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")