// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#""([^"]*)".*"#).unwrap();
let string = "2014-03-20 16:53:39.741 -0700 Information 638 NICOLE Client \"[WebDirect]\" opening a connection from \"24.114.54.155 (24.114.54.155)\" using \"iPad Safari 7.0 [fmwebdirect]\".
2014-03-20 16:53:39.741 -0700 Information 94 NICOLE Client \"[WebDirect] (24.114.54.155) [24.114.54.155]\" opening database \"ProShopPartner_v1\" as \"[Guest]\".
2014-03-20 16:58:45.163 -0700 Information 98 NICOLE Client \"[WebDirect] (24.114.54.155) [24.114.54.155]\" closing database \"ProShopPartner_v1\" as \"[Guest]\".
2014-03-20 16:58:45.163 -0700 Information 22 NICOLE Client \"[WebDirect] (24.114.54.155) [24.114.54.155]\" closing a connection.";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}