using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?(?=9999)9999(?:\.0+)?|\d{1,4}(?:\.\d{1,2})?)$";
string input = @"9999
9999.0
9998.99
9999.00
9999.01
10000.00";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}