import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?(?=9999)9999(?:\\.0+)?|\\d{1,4}(?:\\.\\d{1,2})?)$";
final String string = "9999\n"
+ "9999.0\n"
+ "9998.99\n"
+ "9999.00\n"
+ "9999.01\n"
+ "10000.00";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}