import re
regex = re.compile(r"^(?(?=9999)9999(?:\.0+)?|\d{1,4}(?:\.\d{1,2})?)$", flags=re.MULTILINE)
test_str = ("9999\n"
"9999.0\n"
"9998.99\n"
"9999.00\n"
"9999.01\n"
"10000.00")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")