re = /^(?(?=9999)9999(?:\.0+)?|\d{1,4}(?:\.\d{1,2})?)$/m
str = '9999
9999.0
9998.99
9999.00
9999.01
10000.00'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end