const regex = /^(?(?=9999)9999(?:\.0+)?|\d{1,4}(?:\.\d{1,2})?)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?(?=9999)9999(?:\\.0+)?|\\d{1,4}(?:\\.\\d{1,2})?)$', 'gm')
const str = `9999
9999.0
9998.99
9999.00
9999.01
10000.00`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}