# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/[0-9](?=.*.{4})/x/gmi;t' <<< "1111-2222-3333-4444"