$re = '/[0-9](?=.*.{4})/mi';
$str = '1111-2222-3333-4444';
$subst = "x";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;