const regex = /[0-9](?=.*.{4})/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[0-9](?=.*.{4})', 'gmi')
const str = `1111-2222-3333-4444`;
const subst = `x`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);