use strict;
my $str = '1111-2222-3333-4444';
my $regex = qr/[0-9](?=.*.{4})/mip;
my $subst = 'x';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";