import re
regex = re.compile(r"[0-9](?=.*.{4})", flags=re.MULTILINE | re.IGNORECASE)
test_str = "1111-2222-3333-4444"
subst = "x"
result = regex.sub(subst, test_str)
if result:
print(result)