import Foundation
let pattern = #"[0-9](?=.*.{4})"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"1111-2222-3333-4444"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"x"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)