#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(\"[^"]*)\""
Local $sString = ""asdfadsaD"asdasdad"asdasd""
Local $sSubst = "\1[substitution]"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)