re = /(\"[^"]*)\"/
str = '"asdfadsaD"asdasdad"asdasd"'
subst = '\\1[substitution]'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result