const regex = new RegExp('(\\"[^"]*)\\"', 'g')
const str = `"asdfadsaD"asdasdad"asdasd"`;
const subst = `\1[substitution]`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);