package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\"[^"]*)\"`)
var str = `"asdfadsaD"asdasdad"asdasd"`
var substitution = "\1[substitution]"
fmt.Println(re.ReplaceAllString(str, substitution))
}