$re = '/(\"[^"]*)\"/';
$str = '"asdfadsaD"asdasdad"asdasd"';
$subst = "\1[substitution]";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;