use strict;
my $str = '"asdfadsaD"asdasdad"asdasd"';
my $regex = qr/(\"[^"]*)\"/p;
my $subst = '\\1[substitution]';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";