# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(<[a-z]+\stype="[A|I|1]")(?:[^>]+)?/$1/gm;t' <<< "<ol type=\"A\" lang=\"en-CA\" style=\"margin-bottom: 0in; line-height: 100%\">
<li type=\"A\" s=\"something\"><span>Text</span></li>
<li><span>More text</span></li>
</ol>
<ol type=\"I\" style=\"font-weight: bold;\">
<li><span>Text</span></li>
<li><span>More text</span></li>
</ol>
<ol type=\"1\" style=\"font-weight: bold;\">
<li type=\"I\" another=\"attribute\"><span>Text</span></li>
<li><span>More text</span></li>
</ol>"