// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)(<[a-z]+\stype="[A|I|1]")(?:[^>]+)?"#).unwrap();
let string = "<ol type=\"A\" lang=\"en-CA\" style=\"margin-bottom: 0in; line-height: 100%\">
<li type=\"A\" s=\"something\"><span>Text</span></li>
<li><span>More text</span></li>
</ol>
<ol type=\"I\" style=\"font-weight: bold;\">
<li><span>Text</span></li>
<li><span>More text</span></li>
</ol>
<ol type=\"1\" style=\"font-weight: bold;\">
<li type=\"I\" another=\"attribute\"><span>Text</span></li>
<li><span>More text</span></li>
</ol>";
let substitution = "$1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}