using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(<[a-z]+\stype=""[A|I|1]"")(?:[^>]+)?";
string substitution = @"$1";
string input = @"<ol type=""A"" lang=""en-CA"" style=""margin-bottom: 0in; line-height: 100%"">
<li type=""A"" s=""something""><span>Text</span></li>
<li><span>More text</span></li>
</ol>
<ol type=""I"" style=""font-weight: bold;"">
<li><span>Text</span></li>
<li><span>More text</span></li>
</ol>
<ol type=""1"" style=""font-weight: bold;"">
<li type=""I"" another=""attribute""><span>Text</span></li>
<li><span>More text</span></li>
</ol>";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}