package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(<[a-z]+\stype="[A|I|1]")(?:[^>]+)?`)
var str = `<ol type="A" lang="en-CA" style="margin-bottom: 0in; line-height: 100%">
<li type="A" s="something"><span>Text</span></li>
<li><span>More text</span></li>
</ol>
<ol type="I" style="font-weight: bold;">
<li><span>Text</span></li>
<li><span>More text</span></li>
</ol>
<ol type="1" style="font-weight: bold;">
<li type="I" another="attribute"><span>Text</span></li>
<li><span>More text</span></li>
</ol>`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}