import Foundation
let pattern = #"(<[a-z]+\stype="[A|I|1]")(?:[^>]+)?"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
<ol type="A" lang="en-CA" style="margin-bottom: 0in; line-height: 100%">
<li type="A" s="something"><span>Text</span></li>
<li><span>More text</span></li>
</ol>
<ol type="I" style="font-weight: bold;">
<li><span>Text</span></li>
<li><span>More text</span></li>
</ol>
<ol type="1" style="font-weight: bold;">
<li type="I" another="attribute"><span>Text</span></li>
<li><span>More text</span></li>
</ol>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)