# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(<[a-z]+\stype=\"[A|I|1]\")(?:[^>]+)?"
test_str = ("<ol type=\"A\" lang=\"en-CA\" style=\"margin-bottom: 0in; line-height: 100%\">\n"
" <li type=\"A\" s=\"something\"><span>Text</span></li>\n"
" <li><span>More text</span></li>\n"
"</ol>\n"
"<ol type=\"I\" style=\"font-weight: bold;\">\n"
" <li><span>Text</span></li>\n"
" <li><span>More text</span></li>\n"
"</ol>\n"
"<ol type=\"1\" style=\"font-weight: bold;\">\n"
" <li type=\"I\" another=\"attribute\"><span>Text</span></li>\n"
" <li><span>More text</span></li>\n"
"</ol>")
subst = "$1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.