#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<img.+?class=".*?red.*?""
Local $sString = "<img class="lorem ipsum red" />" & @CRLF & _
"<img class="red" />" & @CRLF & _
"<img class="lorem red ipsum dolor" />" & @CRLF & _
"<img class="red ipsum" />"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")