using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<img.+?class="".*?red.*?""";
string input = @"<img class=""lorem ipsum red"" />
<img class=""red"" />
<img class=""lorem red ipsum dolor"" />
<img class=""red ipsum"" />";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}