// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"<img.+?class=".*?red.*?""#).unwrap();
let string = "<img class=\"lorem ipsum red\" />
<img class=\"red\" />
<img class=\"lorem red ipsum dolor\" />
<img class=\"red ipsum\" />";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}