import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<img.+?class=\".*?red.*?\"";
final String string = "<img class=\"lorem ipsum red\" />\n"
+ "<img class=\"red\" />\n"
+ "<img class=\"lorem red ipsum dolor\" />\n"
+ "<img class=\"red ipsum\" />";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}