re = /<img.+?class=".*?red.*?"/
str = '<img class="lorem ipsum red" />
<img class="red" />
<img class="lorem red ipsum dolor" />
<img class="red ipsum" />'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end