import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?<namespace>(?:[a-zA-Z][a-zA-Z0-9_-]*)(?:\\.[a-zA-Z][a-zA-Z0-9_-]*)+)::(?<rm_publisher>[a-zA-Z]+)-(?<rm_package>[a-zA-Z][a-zA-Z0-9_]+)-(?<rm_class>[a-zA-Z]+)\\.(?<concept_name>[a-zA-Z][a-zA-Z0-9_-]+)\\.(?<release_version>v\\d+(?:\\.\\d+){0,2})(?:-(?<version_status>[a-zA-Z0-9]+))?(?:\\.(?<build_count>\\d))?$";
final String string = "Valid examples:\n"
+ "org.openehr.test::openehr-ehr-comp.test.v1.0.1-alpha.1\n"
+ "org.openehr.test::openehr-ehr-comp.test.v1\n\n\n"
+ "Invalid examples:\n"
+ "org.openehr.test\n"
+ "openehr-ehr-comp.test.v1\n"
+ "org.openehr.test::openehr-ehr-comp.test.v1.0.1-alpha.1c\n"
+ "org.openehr.test::openehr-ehr-comp.test.v1.0.1+alpha.1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}