// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?<namespace>(?:[a-zA-Z][a-zA-Z0-9_-]*)(?:\.[a-zA-Z][a-zA-Z0-9_-]*)+)::(?<rm_publisher>[a-zA-Z]+)-(?<rm_package>[a-zA-Z][a-zA-Z0-9_]+)-(?<rm_class>[a-zA-Z]+)\.(?<concept_name>[a-zA-Z][a-zA-Z0-9_-]+)\.(?<release_version>v\d+(?:\.\d+){0,2})(?:-(?<version_status>[a-zA-Z0-9]+))?(?:\.(?<build_count>\d))?$").unwrap();
let string = "Valid examples:
org.openehr.test::openehr-ehr-comp.test.v1.0.1-alpha.1
org.openehr.test::openehr-ehr-comp.test.v1
Invalid examples:
org.openehr.test
openehr-ehr-comp.test.v1
org.openehr.test::openehr-ehr-comp.test.v1.0.1-alpha.1c
org.openehr.test::openehr-ehr-comp.test.v1.0.1+alpha.1";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}