import Foundation
let pattern = #"^(?<namespace>(?:[a-zA-Z][a-zA-Z0-9_-]*)(?:\.[a-zA-Z][a-zA-Z0-9_-]*)+)::(?<rm_publisher>[a-zA-Z]+)-(?<rm_package>[a-zA-Z][a-zA-Z0-9_]+)-(?<rm_class>[a-zA-Z]+)\.(?<concept_name>[a-zA-Z][a-zA-Z0-9_-]+)\.(?<release_version>v\d+(?:\.\d+){0,2})(?:-(?<version_status>[a-zA-Z0-9]+))?(?:\.(?<build_count>\d))?$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Valid examples:
org.openehr.test::openehr-ehr-comp.test.v1.0.1-alpha.1
org.openehr.test::openehr-ehr-comp.test.v1
Invalid examples:
org.openehr.test
openehr-ehr-comp.test.v1
org.openehr.test::openehr-ehr-comp.test.v1.0.1-alpha.1c
org.openehr.test::openehr-ehr-comp.test.v1.0.1+alpha.1
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)