use strict;
my $str = 'Valid examples:
org.openehr.test::openehr-ehr-comp.test.v1.0.1-alpha.1
org.openehr.test::openehr-ehr-comp.test.v1
Invalid examples:
org.openehr.test
openehr-ehr-comp.test.v1
org.openehr.test::openehr-ehr-comp.test.v1.0.1-alpha.1c
org.openehr.test::openehr-ehr-comp.test.v1.0.1+alpha.1';
my $regex = qr/^(?<namespace>(?:[a-zA-Z][a-zA-Z0-9_-]*)(?:\.[a-zA-Z][a-zA-Z0-9_-]*)+)::(?<rm_publisher>[a-zA-Z]+)-(?<rm_package>[a-zA-Z][a-zA-Z0-9_]+)-(?<rm_class>[a-zA-Z]+)\.(?<concept_name>[a-zA-Z][a-zA-Z0-9_-]+)\.(?<release_version>v\d+(?:\.\d+){0,2})(?:-(?<version_status>[a-zA-Z0-9]+))?(?:\.(?<build_count>\d))?$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}