#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^PHONE\sNUMBER\s+(?P<phone>.+)\R" & @CRLF & _
"CITY\s(?P<city>.+)\R" & @CRLF & _
"EMAIL\s(?P<email>.+)"
Local $sString = "some other text here" & @CRLF & _
"as well as here" & @CRLF & _
"a sender" & @CRLF & _
"or receiver" & @CRLF & _
"" & @CRLF & _
"PHONE NUMBER 09878839934" & @CRLF & _
"CITY CHENNAI " & @CRLF & _
"EMAIL indhuk23@gmail.com" & @CRLF & _
"" & @CRLF & _
"some gibberish here as well"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")