package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^PHONE\sNUMBER\s+(?P<phone>.+)\R
CITY\s(?P<city>.+)\R
EMAIL\s(?P<email>.+)`)
var str = `some other text here
as well as here
a sender
or receiver
PHONE NUMBER 09878839934
CITY CHENNAI
EMAIL indhuk23@gmail.com
some gibberish here as well`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}