$re = '/^PHONE\sNUMBER\s+(?P<phone>.+)\R
CITY\s(?P<city>.+)\R
EMAIL\s(?P<email>.+)/m';
$str = 'some other text here
as well as here
a sender
or receiver
PHONE NUMBER 09878839934
CITY CHENNAI
EMAIL indhuk23@gmail.com
some gibberish here as well';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);