import re
regex = re.compile((r"^PHONE\sNUMBER\s+(?P<phone>.+)\R\n"
r"CITY\s(?P<city>.+)\R\n"
r"EMAIL\s(?P<email>.+)"), flags=re.MULTILINE)
test_str = ("some other text here\n"
"as well as here\n"
"a sender\n"
"or receiver\n\n"
"PHONE NUMBER 09878839934\n"
"CITY CHENNAI \n"
"EMAIL indhuk23@gmail.com\n\n"
"some gibberish here as well")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")