using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^PHONE\sNUMBER\s+(?P<phone>.+)\R
CITY\s(?P<city>.+)\R
EMAIL\s(?P<email>.+)";
string input = @"some other text here
as well as here
a sender
or receiver
PHONE NUMBER 09878839934
CITY CHENNAI
EMAIL indhuk23@gmail.com
some gibberish here as well";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}