// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^PHONE\sNUMBER\s+(?P<phone>.+)\R
CITY\s(?P<city>.+)\R
EMAIL\s(?P<email>.+)").unwrap();
let string = "some other text here
as well as here
a sender
or receiver
PHONE NUMBER 09878839934
CITY CHENNAI
EMAIL indhuk23@gmail.com
some gibberish here as well";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}