#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(\"(\\.|[^"])*\")|(\'(\\.|[^'])*\')"
Local $sString = "function jamel (a,b) { }" & @CRLF & _
"" & @CRLF & _
"on the (favorit () )" & @CRLF & _
"" & @CRLF & _
"on ( (jdjs), () ) (());" & @CRLF & _
" "sefsf sfsf '' sfsfsfsfs" "jslfksj slfkj on" 'sd \' sdfsfsf \' " sdfsf" fsfs'"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")