package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\"(\\.|[^"])*\")|(\'(\\.|[^'])*\')`)
var str = `function jamel (a,b) { }
on the (favorit () )
on ( (jdjs), () ) (());
"sefsf sfsf '' sfsfsfsfs" "jslfksj slfkj on" 'sd \' sdfsfsf \' " sdfsf" fsfs'`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}