$re = '/(\"(\\\\.|[^"])*\")|(\'(\\\\.|[^\'])*\')/';
$str = 'function jamel (a,b) { }
on the (favorit () )
on ( (jdjs), () ) (());
"sefsf sfsf \'\' sfsfsfsfs" "jslfksj slfkj on" \'sd \\\' sdfsfsf \\\' " sdfsf" fsfs\'';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);