re = /(\"(\\.|[^"])*\")|(\'(\\.|[^'])*\')/
str = 'function jamel (a,b) { }
on the (favorit () )
on ( (jdjs), () ) (());
"sefsf sfsf \'\' sfsfsfsfs" "jslfksj slfkj on" \'sd \\\' sdfsfsf \\\' " sdfsf" fsfs\''
# Print the match result
str.scan(re) do |match|
puts match.to_s
end