using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\""(\\.|[^""])*\"")|(\'(\\.|[^'])*\')";
string input = @"function jamel (a,b) { }
on the (favorit () )
on ( (jdjs), () ) (());
""sefsf sfsf '' sfsfsfsfs"" ""jslfksj slfkj on"" 'sd \' sdfsfsf \' "" sdfsf"" fsfs'";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}