# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\S[^\S\n]*)$/$1 - added a word/gm;t' <<< "non empty line
one more line"