$re = '/(\S[^\S\n]*)$/m';
$str = 'non empty line
one more line';
$subst = "$1 - added a word";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;