// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\S[^\S\n]*)$").unwrap();
let string = "non empty line
one more line";
let substitution = "$1 - added a word";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}