#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(\S[^\S\n]*)$"
Local $sString = "non empty line " & @CRLF & _
"" & @CRLF & _
"one more line"
Local $sSubst = "$1 - added a word"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)